Re: [PATCH] libsepol: use explicit type for function parameters

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Jul 14, 2023 at 2:46 PM Christian Göttsche
<cgzones@xxxxxxxxxxxxxx> wrote:
>
> Use a pointer to the explicit type struct policy_file instead of void
> for increased type safety and readability.
>
> Signed-off-by: Christian Göttsche <cgzones@xxxxxxxxxxxxxx>

Acked-by: James Carter <jwcart2@xxxxxxxxx>

> ---
>  libsepol/include/sepol/policydb/avtab.h | 2 +-
>  libsepol/src/avtab.c                    | 6 +++---
>  2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/libsepol/include/sepol/policydb/avtab.h b/libsepol/include/sepol/policydb/avtab.h
> index 7d892879..2bb583f5 100644
> --- a/libsepol/include/sepol/policydb/avtab.h
> +++ b/libsepol/include/sepol/policydb/avtab.h
> @@ -158,7 +158,7 @@ extern int avtab_insert_filename_trans(avtab_t *a, avtab_key_t *key,
>                                        uint32_t otype, const char *name,
>                                        uint8_t name_match,
>                                        uint32_t *present_otype);
> -extern int avtab_filename_trans_read(void *fp, uint32_t vers, avtab_t *a);
> +extern int avtab_filename_trans_read(struct policy_file *fp, uint32_t vers, avtab_t *a);
>
>  #ifdef __cplusplus
>  }
> diff --git a/libsepol/src/avtab.c b/libsepol/src/avtab.c
> index 99fdaa87..7a35fc17 100644
> --- a/libsepol/src/avtab.c
> +++ b/libsepol/src/avtab.c
> @@ -843,7 +843,7 @@ bad:
>         return rc;
>  }
>
> -static int filename_trans_read_one(avtab_t *a, void *fp)
> +static int filename_trans_read_one(avtab_t *a, struct policy_file *fp)
>  {
>         int rc;
>         uint32_t buf[4], len, otype;
> @@ -882,7 +882,7 @@ err:
>         return SEPOL_ERR;
>  }
>
> -static int filename_trans_comp_read_one(avtab_t *a, void *fp)
> +static int filename_trans_comp_read_one(avtab_t *a, struct policy_file *fp)
>  {
>         int rc;
>         uint32_t buf[3], len, ndatum, i, bit, otype;
> @@ -941,7 +941,7 @@ err:
>         return rc;
>  }
>
> -int avtab_filename_trans_read(void *fp, uint32_t vers, avtab_t *a)
> +int avtab_filename_trans_read(struct policy_file *fp, uint32_t vers, avtab_t *a)
>  {
>         uint32_t buf[1], nel, i;
>         int rc;
> --
> 2.40.1
>




[Index of Archives]     [Selinux Refpolicy]     [Linux SGX]     [Fedora Users]     [Fedora Desktop]     [Yosemite Photos]     [Yosemite Camping]     [Yosemite Campsites]     [KDE Users]     [Gnome Users]

  Powered by Linux