Re: [PATCH] selinux: introduce an initial SID for early boot processes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Jun 12, 2023 at 5:01 AM Ondrej Mosnacek <omosnace@xxxxxxxxxx> wrote:
>
> Currently, SELinux doesn't allow distinguishing between kernel threads
> and userspace processes that are started before the policy is first
> loaded - both get the label corresponding to the kernel SID. The only
> way a process that persists from early boot can get a meaningful label
> is by doing a voluntary dyntransition or re-executing itself.
>
> Reusing the kernel label for userspace processes is problematic for
> several reasons:
> 1. The kernel is considered to be a privileged domain and generally
>    needs to have a wide range of permissions allowed to work correctly,
>    which prevents the policy writer from effectively hardening against
>    early boot processes that might remain running unintentionally after
>    the policy is loaded (they represent a potential extra attack surface
>    that should be mitigated).
> 2. Despite the kernel being treated as a privileged domain, the policy
>    writer may want to impose certain special limitations on kernel
>    threads that may conflict with the requirements of intentional early
>    boot processes. For example, it is a good hardening practice to limit
>    what executables the kernel can execute as usermode helpers and to
>    confine the resulting usermode helper processes. However, a
>    (legitimate) process surviving from early boot may need to execute a
>    different set of executables.
> 3. As currently implemented, overlayfs remembers the security context of
>    the process that created an overlayfs mount and uses it to bound
>    subsequent operations on files using this context. If an overlayfs
>    mount is created before the SELinux policy is loaded, these "mounter"
>    checks are made against the kernel context, which may clash with
>    restrictions on the kernel domain (see 2.).
>
> To resolve this, introduce a new initial SID (reusing the slot of the
> former "init" initial SID) that will be assigned to any userspace
> process started before the policy is first loaded. This is easy to do,
> as we can simply label any process that goes through the
> bprm_creds_for_exec LSM hook with the new init-SID instead of
> propagating the kernel SID from the parent.
>
> To provide backwards compatibility for existing policies that are
> unaware of this new semantic of the "init" initial SID, introduce a new
> policy capability "userspace_initial_context" and set the "init" SID to
> the same context as the "kernel" SID unless this capability is set by
> the policy.
>
> Signed-off-by: Ondrej Mosnacek <omosnace@xxxxxxxxxx>
> ---
>  security/selinux/hooks.c                      | 27 +++++++++++++++++++
>  .../selinux/include/initial_sid_to_string.h   |  2 +-
>  security/selinux/include/policycap.h          |  1 +
>  security/selinux/include/policycap_names.h    |  3 ++-
>  security/selinux/include/security.h           |  7 +++++
>  security/selinux/ss/policydb.c                | 27 +++++++++++++++++++
>  6 files changed, 65 insertions(+), 2 deletions(-)

Thanks Ondrej, this looks pretty good to me.  There is some minor
nitpicky stuff below, but those comments are mainly FYIs for future
reference.  Given where we are at in the -rcX cycle, I am going to
hold off on merging this until after the upcoming merge window.

> diff --git a/security/selinux/hooks.c b/security/selinux/hooks.c
> index 99ded60a6b911..dd410ceb178cb 100644
> --- a/security/selinux/hooks.c
> +++ b/security/selinux/hooks.c
> @@ -2264,6 +2264,18 @@ static int selinux_bprm_creds_for_exec(struct linux_binprm *bprm)
>         new_tsec->keycreate_sid = 0;
>         new_tsec->sockcreate_sid = 0;
>
> +       /*
> +        * Before policy is loaded, label any task outside kernel space
> +        * as SECINITSID_INIT, so that any userspace tasks surviving from
> +        * early boot end up with a label different from SECINITSID_KERNEL
> +        * (if the policy chooses to set SECINITSID_INIT != SECINITSID_KERNEL).
> +        */
> +       if (!selinux_initialized()) {
> +               new_tsec->sid = SECINITSID_INIT;
> +               new_tsec->exec_sid = 0; /* just in case */

Style nit, I don't like placing trailing comments on the same line as
code.  Don't respin this patch just for this, but remember this for
future submissions.

> +               return 0;
> +       }
> +
>         if (old_tsec->exec_sid) {
>                 new_tsec->sid = old_tsec->exec_sid;
>                 /* Reset exec SID on execve. */

...

> diff --git a/security/selinux/ss/policydb.c b/security/selinux/ss/policydb.c
> index 97c0074f9312a..240e0fb1d57f9 100644
> --- a/security/selinux/ss/policydb.c
> +++ b/security/selinux/ss/policydb.c
> @@ -863,6 +863,8 @@ void policydb_destroy(struct policydb *p)
>  int policydb_load_isids(struct policydb *p, struct sidtab *s)
>  {
>         struct ocontext *head, *c;
> +       bool secsid_init_supported = ebitmap_get_bit(&p->policycaps,
> +                                                    POLICYDB_CAP_USERSPACE_INITIAL_CONTEXT);

This is another "please don't respin for this", but if you have to
respin for any reason can you change the variable name to
"isid_init_supported" or something similar?  The "secsid" portion of
the name looks wrong to me.

-- 
paul-moore.com




[Index of Archives]     [Selinux Refpolicy]     [Linux SGX]     [Fedora Users]     [Fedora Desktop]     [Yosemite Photos]     [Yosemite Camping]     [Yosemite Campsites]     [KDE Users]     [Gnome Users]

  Powered by Linux