On 9/11/20 7:07 AM, Paul Moore wrote:
+static inline bool checkreqprot_enabled(const struct selinux_state *state)
+{
+ return READ_ONCE(state->checkreqprot);
+}
+
+static inline void checkreqprot_set(struct selinux_state *state, bool value)
+{
+ WRITE_ONCE(state->checkreqprot, value);
+}
This is a nitpick, and I recognize that Stephen already suggested the
use of "*_set()" and "*_enabled()" for names, but if we are going to
name the setter "*_set()" let's also name the getter "*_get()".
Other than that, it looks fine to me.
Sure - I can do that.
Are you expecting something like below (for checkreqprot and enforcing)?
s/checkreqprot_enabled/checkreqprot_get/
s/enforcing_enabled/enforcing_get/
-lakshmi