[Redhat-s390-list] Problems With OSA-Express Card With Boot Image Downloaded 05/04

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Some quick background:

9672-Y36 Generation 5 machine with OSA-Express Ethernet (fast version my CE tells me).

Downloaded and installed Marist distribution back around March - everything worked like a charm (OSA card, etc.).

Tried installing RedHat rawhide downloaded 04/25. Numerous netstat and rpm errors, but the install completed. What I was left with was a barely functioning system - unlike the Marist install which had just about everything I needed up and running from the start. The initialization barely worked because (e)grep wasn't installed for whatever reason. I appreciate that this is a work in progress, so I don't have a problem with this - just background info. The important thing is that the OSA card worked from the 04/25 boot image. I didn't bother trying to configure inetd.conf to test out the OSA on the installed rawhide system. I just dropped back to the Marist system.

Later I downloaded the RedHat rawhide on 05/04 with great hopes that the install problems have been resolved. I found that the boot image (LPAR boot off CD in the HMC) doesn't recognize my OSA card.

Looking for a solution to get the boot off CD to recognize my OSA so I can try the install again. Again, OSA worked with 4/25 boot, fails with 5/4 boot.

BTW, my IODEVICE def for the OSA-Express is 2B00,2

The errors on 5/4 boot:

Select network device eth0

If I select OSA-2 w/ LCS:

Get version mismatch warning
See "starting lcs"
"A partially successful startup read_devno=2b00 write_devno=2b01 was detected ..."
"Channel-Check or interface-Control-Check received"
"... device 2b01 on subchannel 102e, devstat: 00 sch_stat: 04
"... device 2b00 ..."
"s390_process_IRQ (102E) - irb for device 2b01 after channel check"

If I select OSA-Express w/ QDIO/QETH (even though I don't have it defined as QDIO):

OSA express Device address: 0x2b00,0x2b01
See 2 version mismatch warnings
"qeth: loading qeth s/390 Osa-Express driver"
"qeth: parameters not complete"
"SIOCSIFADDR: No such device"
"eth0: unknown interface: No such device"


P.S. The 04/25 install makes the bad assumption that zilo should make the dasda device the boot device. Since dasda was my Marist boot/root, I wanted RedHat to be booted elsewhere. Being able to specify boot device during the install would be a good option.

[Index of Archives]     [Fedora General Discussion]     [LKML]     [Red Hat Install]     [Red Hat Watch]     [Red Hat Development]     [Linux s390]     [Gimp]     [Yosemite News]

  Powered by Linux