External MIDI keyboard and Fedora Core 3

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


Hi all,

I recently acquired a MIDI keyboard, and I'd like to mess about with it in Fedora Core 3. I've got it connected to the game/MIDI port on my soundcard, but no dice. Nothing I've tried has enabled my system to even notice that it's there. I've tried modprobing a number of different modules, but to no avail. arecordmidi results in empty files being generated.

I'm running kernel 2.6.9-1.667
Soundcard: CMI 8738 using module snd-cmipci
I'm also running ALSA, of course, without any of the OSS emulation.

I have no problems with audio from CD's, OGG's or DVD's, even on multiple channels.

I do *not* have a /dev/dsp, /dev/sequencer or /dev/midi even though audio works. Why this is the case, I don't know.

I can play .mid files using timidity++ sans problem.

Here's my modprobe.conf:

alias eth0 forcedeth
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias snd_pcm_oss off
alias snd_mixer_oss off
alias snd-card-0 snd-cmipci
alias snd-slot-0 snd-cmipci
alias net-pf-10 off

And here's the output of lsmod |grep snd

snd_seq_midi 8033 0
snd_seq_midi_event 8385 1 snd_seq_midi
snd_seq 56785 2 snd_seq_midi,snd_seq_midi_event
snd_mpu401 6545 2
snd_cmipci 35173 1
snd_pcm 97993 1 snd_cmipci
snd_page_alloc 9673 1 snd_pcm
snd_opl3_lib 11201 1 snd_cmipci
snd_timer 29765 3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep 9413 1 snd_opl3_lib
gameport 4801 1 snd_cmipci
snd_mpu401_uart 8769 2 snd_mpu401,snd_cmipci
snd_rawmidi 26725 2 snd_seq_midi,snd_mpu401_uart
snd_seq_device 8137 4 snd_seq_midi,snd_seq,snd_opl3_lib,snd_rawmidi
snd 54053 16 snd_seq,snd_mpu401,snd_cmipci,snd_pcm,snd_opl3_lib ,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,s nd_seq_device
soundcore 9889 1 snd

aconnect -lio outpus the following:

client 0: 'System' [type=kernel]
0 'Timer '
1 'Announce '
client 72: 'MPU-401 UART MIDI - Rawmidi 1' [type=kernel]

Were I to run timidity as a server, I get 4 additional ports (128:0..128:3) listed as writable, not as readable. pmidi -p 128:0 foo.mid will play a midi file if timidity's running. If I use aconnect to connect 72:0 to 128:0, I can't play any midi files thru either port.

I'm probably missing something very fundamental, but if I don't ask, I'll never get it sorted.

So, does anyone have any suggestions?



Sound-list mailing list

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux