Re: [Sound] Re: RH 8 & cs4232 problem

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


Monday, December 16, 2002, 9:07:45 PM, you wrote:

BN> Joe Berry (joe@xxxxxxxxxxx) said: 
>> Machine is a Compaq Presario model 1920. I have a MagicMedia 256AV as
>> well as a MagicWave 3Dx.  Under Windows, I recorded all the I/O
>> addresses that I saw.

BN> What were they?

See below

BN> Above you said you tried to load snd-cs4232. These errors (and
BN> the following kernel messages) are from the cs4232 driver, which
BN> is not the ALSA snd-card-cs4232 driver.

Yikes.  I didn't pay close attention to the differences in the names
of the modules. I had built the ALSA binaries from source but since
nothing had seemingly worked right, I had decided to download and
install the rpm files, too.  It's possible I have clobbered something
and made a mess of this system.  I found the original cs4232.o module
and I found (in a different dir) the module snd-cs4232.o.  The size of
the latter file matches what's in my ALSA source directory.  I found
no files named snd-card-cs4232 (with "card" in the middle).  Should I

Now I carefully tried installing again.  Here's a direct cut/paste of
my command and output:

[root@xxxx root]# modprobe snd-cs4232
/lib/modules/2.4.18-18.8.0/kernel/sound/isa/cs423x/snd-cs4232.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or
IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.18-18.8.0/kernel/sound/isa/cs423x/snd-cs4232.o: insmod
/lib/modules/2.4.18-18.8.0/kernel/sound/isa/cs423x/snd-cs4232.o failed
/lib/modules/2.4.18-18.8.0/kernel/sound/isa/cs423x/snd-cs4232.o: insmod snd-cs4232 failed
[root@xxxx root]# dmesg
CS4232 soundcard not found or device busy

The /etc/modules.conf that I used is the following:
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
alias eth0 3c574_cs

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-cs4232

# module options go here
options snd-cs4232 port=0x534 cport=0x120 mpu_port=0x300 fm_port=0x388 irq=5 dma1=0 dma2=-1

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
#alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Here are the specs regarding my sound hardware:

NewMagic Magic Media 256AV
Hardware Version 032
IntReq = 10
Mem Range F4800000 - F4BFFFFF
          F4200000 - F42FFFFF

NeoMagic MagicWave 3Dx Sound System
hardware version 1.0.00
I/O Range 0220-022F
IntReq = 05

DMA 00
DMA 01

I/O: 0x0220 - 0x022F MagicWave 3Dx
     0x0330 - 0x0331   "
     0x0370 - 0x0371   "
     0x0388 - 0x038B   "
     0x03B0 - 0x03BB MagicMedia 256AV
     0x03C0 - 0x03DF   "
     0x0530 - 0x0537 MagicWave 3Dx

IRQs: 5 MagicWave 3Dx
      9 MagicMedia 256AV
     10 MagicMedia 256AV

NeoMagic MagicMedia 256AV NMAZ Codec

PNP device ID=PCI\VEN_10C8&DEV_8005&SUBSYS_B1260E11&REV_20\010800 (IRQ

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux