rpcgen on linux does not generate multithreaded svc code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


     In linux the rpcgen command does not generate multithreaded code.
When I run the rpcgen command on a .x file with -M option (-M generate MT-safe code) in SUN it generates code whose main() has this line:
           int mode = RPC_SVC_MT_AUTO;
But when I run the rpcgen -M command in Linux the code generated is very different and does not have         int mode = RPC_SVC_MT_AUTO;
Due to this during stress test(i.e. multiple parallel requests) to  the rpc server on Linux the client gets many RPC failed error messages.This does not happen in SUN.
Also when I log the thread id in a log file it shows only a single thread which suggests that the svc code is not multithreaded.
What is the solution for this?
Thanks & Regards

Do you Yahoo!?
Yahoo! Mail - More reliable, more storage, less spam

Redhat-devel-list mailing list

[Index of Archives]     [Kernel Newbies]     [Red Hat General]     [Fedora]     [Red Hat Install]     [Linux Kernel Development]     [Yosemite News]

  Powered by Linux