[PATCH 0/3] rcu/nocb updates v2

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

Here is a re-issue of some leftovers from a previous patchset.
Changes since last time:

1) Use rcu_get_jiffies_lazy_flush() instead of the raw variable (thanks Joel)
2) Further comment ordering expectations between grace period end and
   callbacks execution.
   
Thanks.

Frederic Weisbecker (3):
  rcu: Rename jiffies_till_flush to jiffies_lazy_flush
  rcu/nocb: Remove needless LOAD-ACQUIRE
  rcu/nocb: Remove needless full barrier after callback advancing

 kernel/rcu/rcu.h       |  8 ++++----
 kernel/rcu/rcuscale.c  |  6 +++---
 kernel/rcu/tree.c      |  6 ++++++
 kernel/rcu/tree_nocb.h | 26 ++++++++++++--------------
 4 files changed, 25 insertions(+), 21 deletions(-)

-- 
2.42.1




[Index of Archives]     [Linux Samsung SoC]     [Linux Rockchip SoC]     [Linux Actions SoC]     [Linux for Synopsys ARC Processors]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]


  Powered by Linux