> On Feb 1, 2023, at 7:08 AM, Uladzislau Rezki (Sony) <urezki@xxxxxxxxx> wrote: > > The kvfree_rcu()'s single argument name is deprecated therefore > rename it to kvfree_rcu_mightsleep() variant. The goal is explicitly > underline that it is for sleepable contexts. > > Cc: Bryan Tan <bryantan@xxxxxxxxxx> > Cc: Vishnu Dasa <vdasa@xxxxxxxxxx> > Signed-off-by: Uladzislau Rezki (Sony) <urezki@xxxxxxxxx> Reviewed-by: Vishnu Dasa <vdasa@xxxxxxxxxx> > --- > drivers/misc/vmw_vmci/vmci_context.c | 2 +- > drivers/misc/vmw_vmci/vmci_event.c | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/misc/vmw_vmci/vmci_context.c b/drivers/misc/vmw_vmci/vmci_context.c > index 172696abce31..f22b44827e92 100644 > --- a/drivers/misc/vmw_vmci/vmci_context.c > +++ b/drivers/misc/vmw_vmci/vmci_context.c > @@ -687,7 +687,7 @@ int vmci_ctx_remove_notification(u32 context_id, u32 remote_cid) > spin_unlock(&context->lock); > > if (notifier) > - kvfree_rcu(notifier); > + kvfree_rcu_mightsleep(notifier); > > vmci_ctx_put(context); > > diff --git a/drivers/misc/vmw_vmci/vmci_event.c b/drivers/misc/vmw_vmci/vmci_event.c > index 2100297c94ad..5d7ac07623c2 100644 > --- a/drivers/misc/vmw_vmci/vmci_event.c > +++ b/drivers/misc/vmw_vmci/vmci_event.c > @@ -209,7 +209,7 @@ int vmci_event_unsubscribe(u32 sub_id) > if (!s) > return VMCI_ERROR_NOT_FOUND; > > - kvfree_rcu(s); > + kvfree_rcu_mightsleep(s); > > return VMCI_SUCCESS; > } > -- > 2.30.2 >