On Thu, Feb 23, 2023 at 12:36:57PM -0700, Jens Axboe wrote: > On 2/23/23 11:31 AM, Paul E. McKenney wrote: > > On Thu, Feb 23, 2023 at 07:57:13AM -0700, Jens Axboe wrote: > >> On 2/1/23 8:08 AM, Uladzislau Rezki (Sony) wrote: > >>> This small series is based on Paul's "dev" branch. Head is 6002817348a1c610dc1b1c01ff81654cdec12be4 > >>> it renames a single argument of k[v]free_rcu() to its new k[v]free_rcu_mightsleep() name. > >>> > >>> 1. > >>> The problem is that, recently we have run into a precedent when > >>> a user intended to give a second argument to kfree_rcu() API but > >>> forgot to do it in a code so a call became as a single argument > >>> of kfree_rcu() API. > >>> > >>> 2. > >>> Such mistyping can lead to hidden bags where sleeping is forbidden. > >>> > >>> 3. > >>> _mightsleep() prefix gives much more information for which contexts > >>> it can be used for. > >> > >> This patchset seems weird to me. We have a LOT of calls that might > >> sleep, yet we don't suffix them all with _mightsleep(). Why is this > >> any different? Why isn't this just a might_sleep() call in the > >> actual helper, which will suffice for checkers and catch it at > >> runtime as well. > > > > Fair enough, and the situation that this patchset is addressing is also a > > bit unusual. This change was requested by Eric Dumazet due to a situation > > where someone forgot the optional second argument to kfree_rcu(). Now, > > you are right that this would be caught if invoked from a non-sleepable > > context, but there are also cases where sleeping is legal, but where the > > occasional wait for an RCU grace period would be a problem. The checkers > > cannot easily catch this sort of thing, and hence the change in name. > > > > Hey, the combined one/two-argument form seemed like a good idea at > > the time! ;-) > > Hah, not sure what you were smoking back then! If I remember, would you like me to send you some? ;-) Thanx, Paul