On Wed, Nov 04, 2020 at 09:01:33AM -0800, Paul E. McKenney wrote: > A casual reader might be forgiven for being confused by the combination > of "Return" in the above comment and the "void" function type below. > So shouldn't this comment be something like "Add the specified number > of callbacks to the specified segment..."? You are right, sorry and will fix it. > > @@ -330,11 +342,16 @@ void rcu_segcblist_extract_pend_cbs(struct rcu_segcblist *rsclp, > > > > if (!rcu_segcblist_pend_cbs(rsclp)) > > return; /* Nothing to do. */ > > + rclp->len = rcu_segcblist_get_seglen(rsclp, RCU_WAIT_TAIL) + > > + rcu_segcblist_get_seglen(rsclp, RCU_NEXT_READY_TAIL) + > > + rcu_segcblist_get_seglen(rsclp, RCU_NEXT_TAIL); > > This should be a "for" loop. Yes, the number and names of the segments > hasn't changed for a good long time, but nothing like code as above to > inspire Murphy to more mischief. :-/ > > Actually, why not put the summation in the existing "for" loop below? > That would save a line of code in addition to providing less inspiration > for Mr. Murphy. I can do that. Actually Frederic suggested the same thing but I was reluctant as I felt it did not give much LOC benefit. Will revisit it. > > > *rclp->tail = *rsclp->tails[RCU_DONE_TAIL]; > > rclp->tail = rsclp->tails[RCU_NEXT_TAIL]; > > WRITE_ONCE(*rsclp->tails[RCU_DONE_TAIL], NULL); > > - for (i = RCU_DONE_TAIL + 1; i < RCU_CBLIST_NSEGS; i++) > > + for (i = RCU_DONE_TAIL + 1; i < RCU_CBLIST_NSEGS; i++) { > > WRITE_ONCE(rsclp->tails[i], rsclp->tails[RCU_DONE_TAIL]); > > + rcu_segcblist_set_seglen(rsclp, i, 0); > > + } > > } > > > > /* > > @@ -345,7 +362,6 @@ void rcu_segcblist_insert_count(struct rcu_segcblist *rsclp, > > struct rcu_cblist *rclp) > > { > > rcu_segcblist_add_len(rsclp, rclp->len); > > - rclp->len = 0; > > You audited the callers, correct? Yep. thanks, - Joel