> On Jul 19, 2022, at 8:03 PM, Jens Axboe <axboe@xxxxxxxxx> wrote: > > On 7/19/22 1:10 PM, Song Liu wrote: >> >> >>> On Jul 19, 2022, at 11:45 AM, Jens Axboe <axboe@xxxxxxxxx> wrote: >>> >>> On 7/19/22 12:43 PM, Song Liu wrote: >>>> Hi Jens, >>>> >>>> Please consider pulling the following changes on top of your for-5.20/drivers >>>> branch. The major changes are: >>>> 1. Fix md disk_name lifetime problems, by Christoph Hellwig; >>>> 2. Convert prepare_to_wait() to wait_woken() api, by Logan Gunthorpe; >>>> 3. Fix sectors_to_do bitmap issue, by Logan Gunthorpe. >>> >>> This has worse conflicts, it looks like. And not particularly trivial. >>> Do you have a merge resolution? >> >> Hmm... it was a clean merge on top of Linus' tree, but got conflicts >> with linux-next. I guess the conflict is from other changes in the >> block tree? > > Most likely core block changes, I would suspect, from Christoph. > >>> We might want to consider doing a special branch for this... >> >> Yeah, I can port each patch on top of the special branch. To make sure >> they all work. > > I've done a for-5.20/drivers-late branch that you can base on, that > should be the sanest way to do this. Thanks Jens! (assuming the branch is named for-5.20/drivers-post). Please consider the following pull request. The major changes are: 1. Fix md disk_name lifetime problems, by Christoph Hellwig; 2. Convert prepare_to_wait() to wait_woken() api, by Logan Gunthorpe; 3. Fix sectors_to_do bitmap issue, by Logan Gunthorpe. Thanks! Song The following changes since commit bd1ebc67722962962b0d568c26f62bfa7bfe786f: Merge branch 'for-5.20/drivers' into for-5.20/drivers-post (2022-07-19 21:03:38 -0600) are available in the Git repository at: https://git.kernel.org/pub/scm/linux/kernel/git/song/md.git md-next for you to fetch changes up to cce99141d81f4967ed0936bb3506d6813ec9abfb: raid5: fix duplicate checks for rdev->saved_raid_disk (2022-07-19 22:46:28 -0700) ---------------------------------------------------------------- Christoph Hellwig (10): md: fix mddev->kobj lifetime md: fix error handling in md_alloc md: implement ->free_disk md: rename md_free to md_kobj_release md: factor out the rdev overlaps check from rdev_size_store md: stop using for_each_mddev in md_do_sync md: stop using for_each_mddev in md_notify_reboot md: stop using for_each_mddev in md_exit md: only delete entries from all_mddevs when the disk is freed md: simplify md_open Jackie Liu (1): raid5: fix duplicate checks for rdev->saved_raid_disk Logan Gunthorpe (2): md/raid5: Fix sectors_to_do bitmap overflow in raid5_make_request() md/raid5: Convert prepare_to_wait() to wait_woken() api drivers/md/md.c | 310 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------------------------------------------- drivers/md/md.h | 2 ++ drivers/md/raid5.c | 35 ++++++++++++------------ 3 files changed, 183 insertions(+), 164 deletions(-)