Hi Jens, Please consider pulling the following changes on top of your for-5.20/drivers branch. The major changes are: 1. Improve raid5 lock contention, by Logan Gunthorpe. 2. Misc fixes to raid5, by Logan Gunthorpe. 3. Fix race condition with md_reap_sync_thread(), by Guoqing Jiang. Thanks, Song The following changes since commit 197f80d97e9ccc8a496f4935ba939f3ed7432d53: drbd: bm_page_async_io: fix spurious bitmap "IO error" on large volumes (2022-06-27 06:29:22 -0600) are available in the Git repository at: https://git.kernel.org/pub/scm/linux/kernel/git/song/md.git md-next for you to fetch changes up to ff4ec5f79108cf82fe7168547c76fe754c4ade0a: md: Fix spelling mistake in comments (2022-07-03 07:59:16 -0700) ---------------------------------------------------------------- Chris Webb (1): md: Explicitly create command-line configured devices Guoqing Jiang (1): md: unlock mddev before reap sync_thread in action_store Logan Gunthorpe (25): md/raid5-log: Drop extern decorators for function prototypes md/raid5-ppl: Drop unused argument from ppl_handle_flush_request() md/raid5: suspend the array for calls to log_exit() md/raid5-cache: Take mddev_lock in r5c_journal_mode_show() md/raid5-cache: Drop RCU usage of conf->log md/raid5-cache: Clear conf->log after finishing work md/raid5-cache: Annotate pslot with __rcu notation md: Use enum for overloaded magic numbers used by mddev->curr_resync md: Ensure resync is reported after it starts md: Notify sysfs sync_completed in md_reap_sync_thread() md/raid5: Make logic blocking check consistent with logic that blocks md/raid5: Factor out ahead_of_reshape() function md/raid5: Refactor raid5_make_request loop md/raid5: Move stripe_add_to_batch_list() call out of add_stripe_bio() md/raid5: Move common stripe get code into new find_get_stripe() helper md/raid5: Factor out helper from raid5_make_request() loop md/raid5: Drop the do_prepare flag in raid5_make_request() md/raid5: Move read_seqcount_begin() into make_stripe_request() md/raid5: Refactor for loop in raid5_make_request() into while loop md/raid5: Keep a reference to last stripe_head for batch md/raid5: Refactor add_stripe_bio() md/raid5: Check all disks in a stripe_head for reshape progress md/raid5: Pivot raid5_make_request() md/raid5: Improve debug prints md/raid5: Increase restriction on max segments per request Song Liu (1): MAINTAINERS: add patchwork link to linux-raid project Zhang Jiaming (1): md: Fix spelling mistake in comments MAINTAINERS | 1 + drivers/md/dm-raid.c | 1 + drivers/md/md-autodetect.c | 1 + drivers/md/md-cluster.c | 4 +- drivers/md/md.c | 76 ++++++++++++++++--------- drivers/md/md.h | 16 ++++++ drivers/md/raid5-cache.c | 40 +++++++------ drivers/md/raid5-log.h | 77 ++++++++++++------------- drivers/md/raid5-ppl.c | 2 +- drivers/md/raid5.c | 646 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++------------------------------------------------------------------------- 10 files changed, 549 insertions(+), 315 deletions(-)