On 2022-04-26 19:32, Guoqing Jiang wrote: > > > On 4/21/22 3:54 AM, Logan Gunthorpe wrote: >> Break immediately if raid5_get_active_stripe() returns NULL and deindent >> the rest of the loop. Annotate this check with an unlikely(). >> >> This makes the code easier to read and reduces the indentation level. >> >> No functional changes intended. >> >> Signed-off-by: Logan Gunthorpe<logang@xxxxxxxxxxxx> >> --- >> drivers/md/raid5.c | 109 +++++++++++++++++++++++---------------------- >> 1 file changed, 55 insertions(+), 54 deletions(-) >> >> diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c >> index 97b23c18402b..cda6857e6207 100644 >> --- a/drivers/md/raid5.c >> +++ b/drivers/md/raid5.c >> @@ -5906,68 +5906,69 @@ static bool raid5_make_request(struct mddev >> *mddev, struct bio * bi) > > ... > >> + if (unlikely(!sh)) { >> + /* cannot get stripe, just give-up */ >> + bi->bi_status = BLK_STS_IOERR; >> + break; >> + } > > > Nit, I would suggest to keep below original comment. But the original comment was plainly wrong... Logan