On Thu, Nov 21, 2019 at 2:37 AM <jgq516@xxxxxxxxx> wrote: > > From: Guoqing Jiang <guoqing.jiang@xxxxxxxxxxxxxxx> > > Previously, wb_info_pool and wb_list stuffs are introduced > to address potential data inconsistence issue for write > behind device. > > Now rename them to serial related name, since the same > mechanism will be used to address reorder overlap write > issue for raid1. > > Signed-off-by: Guoqing Jiang <guoqing.jiang@xxxxxxxxxxxxxxx> [...] > rdev_for_each(rdev, mddev) { > if (test_bit(WriteMostly, &rdev->flags) && > - rdev_init_wb(rdev)) > + rdev_init_serial(rdev)) > creat_pool = true; As we are renaming things, let's also change creat_pool => create_pool. Thanks, Song