On Tue, 7 Jun 2011 23:49:31 +0900 Namhyung Kim <namhyung@xxxxxxxxx> wrote: > Use COUNTER()/NEEDED() macro instead of open-coding them. > > Signed-off-by: Namhyung Kim <namhyung@xxxxxxxxx> > --- > drivers/md/bitmap.c | 6 +++--- > 1 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/drivers/md/bitmap.c b/drivers/md/bitmap.c > index 70bd738b8b99..8b40bd71bb4a 100644 > --- a/drivers/md/bitmap.c > +++ b/drivers/md/bitmap.c > @@ -1332,7 +1332,7 @@ int bitmap_startwrite(struct bitmap *bitmap, sector_t offset, unsigned long sect > return 0; > } > > - if (unlikely((*bmc & COUNTER_MAX) == COUNTER_MAX)) { > + if (unlikely(COUNTER(*bmc) == COUNTER_MAX)) { > DEFINE_WAIT(__wait); > /* note that it is safe to do the prepare_to_wait > * after the test as long as we do it before dropping > @@ -1404,10 +1404,10 @@ void bitmap_endwrite(struct bitmap *bitmap, sector_t offset, unsigned long secto > sysfs_notify_dirent_safe(bitmap->sysfs_can_clear); > } > > - if (!success && ! (*bmc & NEEDED_MASK)) > + if (!success && !NEEDED(*bmc)) > *bmc |= NEEDED_MASK; > > - if ((*bmc & COUNTER_MAX) == COUNTER_MAX) > + if (COUNTER(*bmc) == COUNTER_MAX) > wake_up(&bitmap->overflow_wait); > > (*bmc)--; Thanks.... Personally I loathe such macros - I prefer things to be open codes so I can see what is happening without having to guess. But as we have the macros and they are already in use we should be consistent and use them everywhere. So I'll apply the patch. Thanks, NeilBrown -- To unsubscribe from this list: send the line "unsubscribe linux-raid" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html