On Monday August 27, dan.j.williams@xxxxxxxxx wrote: > > - s.locked += handle_write_operations5(sh, 0, 1); > > + s.locked += handle_write_operations5(sh, 1, 1); > How about for clarity: > s.locked += handle_write_operations5(sh, RECONSTRUCT_WRITE, 1); > Nope. That second argument is a boolean, not an enum. If it was changed to 'writemode' (or similar) and the code in handle_write_operations5 were changed to switch(writemode) { case RECONSTRUCT_WRITE: .... case READ_MODIFY_WRITE: .... } Then it would make sense to use RECONSTRUCT_WRITE in the call - and the code would probably be more readable on the whole. But as it is, either 'true' or '1' should go there. NeilBrown - To unsubscribe from this list: send the line "unsubscribe linux-raid" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html