On 19.02.2018 15:48, Tanu Kaskinen wrote: > The suspend cause isn't yet used by any of the handlers. The alsa sink > and source will use it to sync the mixer when the SESSION suspend cause > is removed. Currently the syncing is done in pa_sink/source_suspend(), > and I want to change that, because pa_sink/source_suspend() shouldn't > have any alsa specific code. > --- > src/modules/alsa/alsa-sink.c | 11 +++++++++-- > src/modules/alsa/alsa-source.c | 11 +++++++++-- > src/modules/bluetooth/module-bluez4-device.c | 22 ++++++++++++++++++---- > src/modules/bluetooth/module-bluez5-device.c | 22 ++++++++++++++++++---- > src/modules/echo-cancel/module-echo-cancel.c | 2 +- > src/modules/module-combine-sink.c | 10 +++++++++- > src/modules/module-equalizer-sink.c | 2 +- > src/modules/module-esound-sink.c | 11 +++++++++-- > src/modules/module-ladspa-sink.c | 2 +- > src/modules/module-null-sink.c | 6 ++++-- > src/modules/module-null-source.c | 2 +- > src/modules/module-pipe-sink.c | 9 ++++++--- > src/modules/module-remap-sink.c | 2 +- > src/modules/module-sine-source.c | 2 +- > src/modules/module-solaris.c | 23 ++++++++++++++++++----- > src/modules/module-tunnel-sink-new.c | 12 ++++++++++-- > src/modules/module-tunnel-source-new.c | 12 ++++++++++-- > src/modules/module-virtual-sink.c | 2 +- > src/modules/module-virtual-surround-sink.c | 2 +- > src/modules/oss/module-oss.c | 24 ++++++++++++++++++------ > src/modules/raop/raop-sink.c | 9 ++++++++- > src/pulsecore/sink.c | 15 +++++++++------ > src/pulsecore/sink.h | 23 +++++++++++++++++++++++ > src/pulsecore/source.c | 15 +++++++++------ > src/pulsecore/source.h | 23 +++++++++++++++++++++++ > 25 files changed, 218 insertions(+), 56 deletions(-) > I would rename pa_sink_message_set_state to pa_sink_set_state_message because the first name sounds like a function name. Also there may be some changes required due to the new patch 2 of the series. Otherwise looks good.