These patches bring the volume ramping feature that has not been applied to upstream. This topic was also mentioned a few months ago. : https://lists.freedesktop.org/archives/pulseaudio-discuss/2016-June/026459.html The original patches are at below. : https://lists.freedesktop.org/archives/pulseaudio-discuss/2012-August/014351.html Here are resubmitting patches without client API part as we discussed on IRC before. Please note that Jaska Uimonen's patches are from tizen project, because it seems more refined than the above original patches. And new volume ramp factor APIs are added to sink-input which will be used instead of the previous volume ramp setting API of sink-input. Notes: v2 changelog * Not applying the commit "volume ramp: add volume ramping to sink" * Added volume ramp factor to sink-input v3 changelog * Revision according to Arun's comments - compliance with the PA coding convention - reduced duplicated codes by adding a static function - using a time variable in pa_cvolume_ramp_int structure Sangchul Lee (4): volume ramp: additions to the low level infra volume ramp: adding volume ramping to sink-input Refactor codes regarding volume ramp mix: Use time variable as a member of pa_cvolume_ramp_int structure Jaska Uimonen (2): sink-input, volume: Add support for volume ramp factor sink-input: Remove pa_sink_input_set_volume_ramp() src/map-file | 7 ++ src/pulse/def.h | 13 +- src/pulse/volume.c | 111 +++++++++++++++++ src/pulse/volume.h | 46 +++++++ src/pulsecore/mix.c | 300 +++++++++++++++++++++++++++++++++++++++++++++ src/pulsecore/mix.h | 27 ++++ src/pulsecore/sink-input.c | 140 +++++++++++++++++++++ src/pulsecore/sink-input.h | 16 ++- 8 files changed, 658 insertions(+), 2 deletions(-) -- 2.7.4