[PATCH] pstream: Rename "do_something" function

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, 2013-04-05 at 11:19 +0200, David Henningsson wrote:
> Rename it to "do_pstream_read_write" that better describes what the
> function does.
> 
> Signed-off-by: David Henningsson <david.henningsson at canonical.com>
> ---
>  src/pulsecore/pstream.c |    6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/src/pulsecore/pstream.c b/src/pulsecore/pstream.c
> index c0262a7..7538a86 100644
> --- a/src/pulsecore/pstream.c
> +++ b/src/pulsecore/pstream.c
> @@ -168,7 +168,7 @@ struct pa_pstream {
>  static int do_write(pa_pstream *p);
>  static int do_read(pa_pstream *p);
>  
> -static void do_something(pa_pstream *p) {
> +static void do_pstream_read_write(pa_pstream *p) {
>      pa_assert(p);
>      pa_assert(PA_REFCNT_VALUE(p) > 0);
>  
> @@ -206,7 +206,7 @@ static void io_callback(pa_iochannel*io, void *userdata) {
>      pa_assert(PA_REFCNT_VALUE(p) > 0);
>      pa_assert(p->io == io);
>  
> -    do_something(p);
> +    do_pstream_read_write(p);
>  }
>  
>  static void defer_callback(pa_mainloop_api *m, pa_defer_event *e, void*userdata) {
> @@ -217,7 +217,7 @@ static void defer_callback(pa_mainloop_api *m, pa_defer_event *e, void*userdata)
>      pa_assert(p->defer_event == e);
>      pa_assert(p->mainloop == m);
>  
> -    do_something(p);
> +    do_pstream_read_write(p);
>  }
>  
>  static void memimport_release_cb(pa_memimport *i, uint32_t block_id, void *userdata);

Ack.

-- 
Tanu



[Index of Archives]     [Linux Audio Users]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux