This is a series of patches containing either fixes, improvements, or new features. Most of it is vary straightforward and I'd hope quick and easy to review. However patch 0003 does a fair bit of work in reducing a series of common patterns down to a few macros and a more generic store function. This ends up unifying a lot of things to and making the end result much cleaner to read plus add future features of the same pattern. I am unsure if I've got the macros correct. Everything compiles, all is tested and working correctly - but maybe I could use some guidance on formatting and style there? Should they be in a header? The debug statement patch was invaluable for debugging some issues on another users machine. I will likely add some more debug in future. The platform_profile issue.. It seems there is a race bewteen asus-wmi and an AMD driver to register the platform_profile on boot on some laptops. The asus-wmi driver can live without platform_profile quite fine as the feature is really just a wrapper around throttle_thermal_policy. But it does raise the question of "what's going on here?". Many thanks, Luke. Luke D. Jones (9): platform/x86: asus-wmi: add debug print in more key places platform/x86: asus-wmi: don't fail if platform_profile already registered platform/x86: asus-wmi: add macros and expose min/max sysfs for ppt tunables platform/x86: asus-wmi: reduce code duplication with macros platform/x86: asus-wmi: use WMI_SIMPLE_SHOW in more places platform/x86: asus-wmi: add panel-fhd functionality platform/x86: asus-wmi: add enable/disable CPU cores platform/x86: asus-wmi: add apu_mem setting platform/x86: asus-wmi: add setting dGPU TGP .../ABI/testing/sysfs-platform-asus-wmi | 78 +- drivers/platform/x86/asus-wmi.c | 1248 ++++++++--------- include/linux/platform_data/x86/asus-wmi.h | 12 + 3 files changed, 688 insertions(+), 650 deletions(-) -- 2.45.1