On Mon, 9 Oct 2023, Shyam Sundar S K wrote: > As we have a separate header for amd_pmc driver, move the common strutures, > enums, and macros to the header file. > > Suggested-by: Sanket Goswami <Sanket.Goswami@xxxxxxx> > Signed-off-by: Shyam Sundar S K <Shyam-sundar.S-k@xxxxxxx> > --- > +#define RESPONSE_REGISTER_LOOP_MAX 20000 This is borderline, I'd add prefix for this. > +#define DELAY_MIN_US 2000 > +#define DELAY_MAX_US 3000 > +#define FIFO_SIZE 4096 These look way too generic names when they are now disconnected from the code using them, not that DELAY_* ever was a good name for anything :-). > +enum amd_pmc_def { > + MSG_TEST = 0x01, > + MSG_OS_HINT_PCO, > + MSG_OS_HINT_RN, > +}; I suggest you consider adding a prefix for these too. -- i.