No point to waste a vector for cleaning up the leftovers of a moved interrupt. Aside of that this must be the lowest priority of all vectors which makes FRED systems utilizing vectors 0x10-0x1f more complicated than necessary. Schedule a timer instead. Changes since v1: * Add a lockdep_assert_held() statement to get rid of a bad comment that claims __vector_cleanup() needs to be called with vector_lock held. (Peter Zijlstra). Thomas Gleixner (2): x86/vector: Rename send_cleanup_vector() to vector_schedule_cleanup() x86/vector: Replace IRQ_MOVE_CLEANUP_VECTOR with a timer callback Xin Li (1): tools: Get rid of IRQ_MOVE_CLEANUP_VECTOR from tools arch/x86/include/asm/hw_irq.h | 4 +- arch/x86/include/asm/idtentry.h | 1 - arch/x86/include/asm/irq_vectors.h | 7 -- arch/x86/kernel/apic/vector.c | 106 ++++++++++++++---- arch/x86/kernel/idt.c | 1 - arch/x86/platform/uv/uv_irq.c | 2 +- drivers/iommu/amd/iommu.c | 2 +- drivers/iommu/hyperv-iommu.c | 4 +- drivers/iommu/intel/irq_remapping.c | 2 +- tools/arch/x86/include/asm/irq_vectors.h | 7 -- .../beauty/tracepoints/x86_irq_vectors.sh | 2 +- 11 files changed, 90 insertions(+), 48 deletions(-) -- 2.34.1