On 10/21/2022 1:34 PM, Jithu Joseph wrote:
Refactor header version as a parameter and expose this function.
Isn't the header version part of the microcode data itself?
Microcode Format
+----------------------+ Base
|Header Version |
+----------------------+
|Update revision |
+----------------------+
If so, why the need to pass it as a parameter to sanity_check()?
No functional change intended.
Maybe skip this statement. Apart from adding a parameter to an newly
exported function, there is a change in an error print as well.
diff --git a/arch/x86/kernel/cpu/microcode/intel.c b/arch/x86/kernel/cpu/microcode/intel.c
index 5473b094baee..bc3f33a25d7a 100644
--- a/arch/x86/kernel/cpu/microcode/intel.c
+++ b/arch/x86/kernel/cpu/microcode/intel.c
@@ -37,6 +37,8 @@
#include <asm/setup.h>
#include <asm/msr.h>
+#define MICROCODE_HEADER_VER 1
+
Should this define be in a central location, like microcode_intel.h?
You would soon be adding a define for IFS_HEADER_VER. Having them
defined together would make it easier to follow.
Sohil