Hi, On 9/23/22 08:33, cgel.zte@xxxxxxxxx wrote: > From: ye xingchen <ye.xingchen@xxxxxxxxxx> > > Replace the open-code with sysfs_emit() to simplify the code. > > Signed-off-by: ye xingchen <ye.xingchen@xxxxxxxxxx> Thank you for your patch, I've applied this patch to my review-hans branch: https://git.kernel.org/pub/scm/linux/kernel/git/pdx86/platform-drivers-x86.git/log/?h=review-hans Note it will show up in my review-hans branch once I've pushed my local branch there, which might take a while. Once I've run some tests on this branch the patches there will be added to the platform-drivers-x86/for-next branch and eventually will be included in the pdx86 pull-request to Linus for the next merge-window. Regards, Hans > --- > .../x86/intel/uncore-frequency/uncore-frequency-common.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/platform/x86/intel/uncore-frequency/uncore-frequency-common.c b/drivers/platform/x86/intel/uncore-frequency/uncore-frequency-common.c > index 84eabd6156bb..6cbbf9bbeefb 100644 > --- a/drivers/platform/x86/intel/uncore-frequency/uncore-frequency-common.c > +++ b/drivers/platform/x86/intel/uncore-frequency/uncore-frequency-common.c > @@ -113,7 +113,7 @@ show_uncore_perf_status(current_freq_khz); > struct uncore_data *data = container_of(attr, struct uncore_data,\ > member_name##_dev_attr);\ > \ > - return scnprintf(buf, PAGE_SIZE, "%u\n", \ > + return sysfs_emit(buf, "%u\n", \ > data->member_name); \ > } \ >