On Wed, Jan 19, 2022 at 08:51:29PM +0200, Andy Shevchenko wrote: > On Sat, Jan 15, 2022 at 04:45:39PM +0100, Uwe Kleine-König wrote: > > On Fri, Jan 14, 2022 at 03:04:38PM +0200, Andy Shevchenko wrote: > > > On Thu, Jan 13, 2022 at 08:43:58PM +0100, Uwe Kleine-König wrote: > > > > > It'd certainly be good to name anything that doesn't correspond to one > > > > > of the existing semantics for the API (!) something different rather > > > > > than adding yet another potentially overloaded meaning. > > > > > > > > It seems we're (at least) three who agree about this. Here is a patch > > > > fixing the name. > > > > > > And similar number of people are on the other side. > > > > If someone already opposed to the renaming (and not only the name) I > > must have missed that. > > > > So you think it's a good idea to keep the name > > platform_get_irq_optional() despite the "not found" value returned by it > > isn't usable as if it were a normal irq number? > > I meant that on the other side people who are in favour of Sergey's patch. > Since that I commented already that I opposed the renaming being a standalone > change. > > Do you agree that we have several issues with platform_get_irq*() APIs? > > 1. The unfortunate naming unfortunate naming for the currently implemented semantic, yes. > 2. The vIRQ0 handling: a) WARN() followed by b) returned value 0 I'm happy with the vIRQ0 handling. Today platform_get_irq() and it's silent variant returns either a valid and usuable irq number or a negative error value. That's totally fine. > 3. The specific cookie for "IRQ not found, while no error happened" case Not sure what you mean here. I have no problem that a situation I can cope with is called an error for the query function. I just do error handling and continue happily. So the part "while no error happened" is irrelevant to me. Additionally I see the problems: 4. The semantic as implemented in Sergey's patch isn't better than the current one. platform_get_irq*() is still considerably different from (clk|gpiod)_get* because the not-found value for the _optional variant isn't usuable for the irq case. For clk and gpio I get rid of a whole if branch, for irq I only change the if-condition. (And if that change is considered good or bad seems to be subjective.) For the idea to add a warning to platform_get_irq_optional for all but -ENXIO (and -EPROBE_DEFER), I see the problem: 5. platform_get_irq*() issuing an error message is only correct most of the time and given proper error handling in the caller (which might be able to handle not only -ENXIO but maybe also -EINVAL[1]) the error message is irritating. Today platform_get_irq() emits an error message for all but -EPROBE_DEFER. As soon as we find a driver that handles -EINVAL we need a function platform_get_irq_variant1 to be silent for -EINVAL, -EPROBE_DEFER and -ENXIO (or platform_get_irq_variant2 that is only silent for -EINVAL and -EPROBE_DEFER?) IMHO a query function should always be silent and let the caller do the error handling. And if it's only because mydev: IRQ index 0 not found is worse than mydev: neither TX irq not a muxed RX/TX irq found . Also "index 0" is irritating for devices that are expected to have only a single irq (i.e. the majority of all devices). Yes, I admit, we can safe some code by pushing the error message in a query function. But that doesn't only have advantages. Best regards Uwe [1] Looking through the source I wonder: What are the errors that can happen in platform_get_irq*()? (calling everything but a valid irq number an error) Looking at many callers, they only seem to expect "not found" and some "probe defer" (even platform_get_irq() interprets everything but -EPROBE_DEFER as "IRQ index %u not found\n".) IMHO before we should consider to introduce a platform_get_irq*() variant with improved semantics, some cleanup in the internals of the irq lookup are necessary. -- Pengutronix e.K. | Uwe Kleine-König | Industrial Linux Solutions | https://www.pengutronix.de/ |
Attachment:
signature.asc
Description: PGP signature