On Mon, Jan 10, 2022 at 11:07:03PM +0200, Andy Shevchenko wrote: > On Mon, Jan 10, 2022 at 09:10:14PM +0100, Uwe Kleine-König wrote: > > On Mon, Jan 10, 2022 at 10:54:48PM +0300, Sergey Shtylyov wrote: > > > This patch is based on the former Andy Shevchenko's patch: > > > > > > https://lore.kernel.org/lkml/20210331144526.19439-1-andriy.shevchenko@xxxxxxxxxxxxxxx/ > > > > > > Currently platform_get_irq_optional() returns an error code even if IRQ > > > resource simply has not been found. It prevents the callers from being > > > error code agnostic in their error handling: > > > > > > ret = platform_get_irq_optional(...); > > > if (ret < 0 && ret != -ENXIO) > > > return ret; // respect deferred probe > > > if (ret > 0) > > > ...we get an IRQ... > > > > > > All other *_optional() APIs seem to return 0 or NULL in case an optional > > > resource is not available. Let's follow this good example, so that the > > > callers would look like: > > > > > > ret = platform_get_irq_optional(...); > > > if (ret < 0) > > > return ret; > > > if (ret > 0) > > > ...we get an IRQ... > > > > The difference to gpiod_get_optional (and most other *_optional) is that > > you can use the NULL value as if it were a valid GPIO. > > The problem is not only there, but also in the platform_get_irq() and that > problem is called vIRQ0. Or as Linus put it "_cookie_" for IRQ, which never > ever should be 0. IMHO it's best to avoid yielding zero for a value that should be interpreted as an (virtual) irq. Then callers don't even have to consider if it's a valid value or not. > > As this isn't given with for irqs, I don't think changing the return > > value has much sense. In my eyes the problem with platform_get_irq() and > > platform_get_irq_optional() is that someone considered it was a good > > idea that a global function emits an error message. The problem is, > > that's only true most of the time. (Sometimes the caller can handle an > > error (here: the absence of an irq) just fine, sometimes the generic > > error message just isn't as good as a message by the caller could be. > > (here: The caller could emit "TX irq not found" which is a much nicer > > message than "IRQ index 5 not found".) > > > > My suggestion would be to keep the return value of > > platform_get_irq_optional() as is, but rename it to > > platform_get_irq_silent() to get rid of the expectation invoked by the > > naming similarity that motivated you to change > > platform_get_irq_optional(). > > This won't fix the issue with vIRQ0. Is the patch about vIRQ0, or did you only start to consider it when I said that for gpio NULL is a dummy value? If the former, the commit log should better mention that. Anyhow, I still think renaming platform_get_irq_optional() to platform_get_irq_silent() is a good idea and the patches in this thread are not. Best regards Uwe -- Pengutronix e.K. | Uwe Kleine-König | Industrial Linux Solutions | https://www.pengutronix.de/ |
Attachment:
signature.asc
Description: PGP signature