On 11/25/21, Dov Murik <dovmurik@xxxxxxxxxxxxx> wrote: > On 24/11/2021 22:34, Martin Fernandez wrote: >> +extern u64 e820__range_mark_as_crypto(u64 start, u64 size); > > I suggest: e820__range_mark_as_crypto_capable > (as you do in other function and field names) > Yes, good catch. Thanks. >> /* Remove a range of memory from the E820 table: */ >> @@ -573,6 +604,9 @@ u64 __init e820__range_remove(u64 start, u64 size, >> enum e820_type old_type, bool >> /* Is the new range completely covered? */ >> if (entry->addr < start && entry_end > end) { >> e820__range_add(end, entry_end - end, entry->type); >> + if (entry->crypto_capable) >> + e820__range_mark_as_crypto(end, entry_end - end); >> + > > Why introduce this new function call instead of adding an extra > 'crypto_capable' argument to e820__range_add() ? I thought about it, but I would like not to change the signature of e820__range_add. Either way, here I could use __e820__range_add which it does accept crypto_capable as an argument, just as I did in e820__range_update.