On Fri, Sep 3, 2021 at 3:22 AM Daniel Dadap <ddadap@xxxxxxxxxx> wrote: > On 9/2/21 6:20 PM, Thomas Weißschuh wrote: ... > >> +#define WMAA_WMI_GUID "603E9613-EF25-4338-A3D0-C46177516DB7" > >> + > >> +static const struct wmi_device_id wmaa_backlight_wmi_id_table[] = { > >> + { .guid_string = WMAA_WMI_GUID }, > > This could also be inlined as: > > { "603E9613-EF25-4338-A3D0-C46177516DB7" }, > > > > More a stylistic thing though. > > I considered that when switching to MODULE_DEVICE_TABLE, since the value > is now only used in one place, but looking at other similar drivers, it > does seem that the most common convention is to define the GUID as a > macro even if it's only used once. I'll leave this as-is, I think. I'm on Daniel's side here. But the problem I have noticed with the proposal is different, i.e. it loses the C99 style of member definitions. -- With Best Regards, Andy Shevchenko