On Mon, Apr 8, 2019 at 9:36 PM Rajat Jain <rajatja@xxxxxxxxxx> wrote: > On Mon, Apr 8, 2019 at 10:02 AM Andy Shevchenko > <andy.shevchenko@xxxxxxxxx> wrote: > > On Fri, Apr 5, 2019 at 11:36 PM Rajat Jain <rajatja@xxxxxxxxxx> wrote: > > Perhaps something like > > > > pmcdev->check_counters = false; > > /* User doesn't want to be warned */ > > if (!warn_on...) > > return 0; > > /* We do suspend via firmware */ > > if (...) > > return 0; > > ... > > > > ? > > I guess what you mean is one conditional per line. Sure, I will do that. Yes > > > +static inline bool pc10_failed(struct pmc_dev *pmcdev) > > > > To be or not to be? :-) > > Perhaps names of the functions should be > > > > pmc_code_is_pc10_failed() > > > > and so on > > I think the suggestion is to use pmc_core_* as the function names. OK, > I will rename the functions to: > > pmc_core_pc10_failed() > and > pmc_core_s0ix_failed() And verb "to be". See above. > > Can't we utilize existing print helpers? > > I didn't quite see any existing print helpers in this file. I took > this code from pmc_core_slps0_dbg_show(), and I think although I can > abstract out this code into a static function, the calling code need > to use seq_printf(s,...) and dev_warn(dev,...) respectively. - so > might be overkill (did not feel that the benefits were worth it). > Please let me know if you have any suggestions and will be happy to > use them. Instead of adding module parameter and doing these prints, perhaps introduce another debugfs node. -- With Best Regards, Andy Shevchenko