Hi,
On 07-08-18 13:19, Andy Shevchenko wrote:
On Tue, 2018-08-07 at 10:05 +0200, Hans de Goede wrote:
Some devices have multiple I2cSerialBus resources and for things to
work
an i2c-client must be instantiated for each, each with its own
i2c_device_id.
Normally we only instantiate an i2c-client for the first resource,
using
the ACPI HID as id.
This commit adds a list of HIDs of devices, which need multiple i2c-
clients
instantiated from a single fwnode, to
acpi_device_enumeration_by_parent and
makes acpi_device_enumeration_by_parent return false for these devices
so
that a platform device will be instantiated.
This allows the drivers/platform/x86/i2c-multi-instantiate.c driver,
which
knows which i2c_device_id to use for each resource, to bind to the
fwnode
and initiate an i2c-client for each resource.
+ /*
+ * These devices have multiple I2cSerialBus resources and an
i2c-client
+ * must be instantiated for each, each with its own
i2c_device_id.
+ * Normally we only instantiate an i2c-client for the first
resource,
+ * using the ACPI HID as id. These special cases are handled by
the
+ * drivers/platform/x86/i2c-multi-instantiate.c driver, which
knows
+ * which i2c_device_id to use for each resource.
+ */
+ static const struct acpi_device_id i2c_multi_instantiate_ids[] =
{
+ {"BSG1160", 0},
+ {"", 0},
+ };
Style nits:
- can we move it outside of function?
Sure, but there are 2 existing users of an array of acpi_device_id-s
combined with an acpi_match_device_ids() call and both have the array
inside the function, so for consistency it seems better to keep it
where it is.
- terminator better without comma
Agreed, will fix for v4.
- is this existing style in the file and / or files in this folder for
IDs? (I mean unnecessary 0:s and empty string?
It seems that all variants one can come up with are already used inside
this single file.
I agree that less is more, so I will change this to:
static const struct acpi_device_id i2c_multi_instantiate_ids[] = {
{"BSG1160", },
{}
};
For v4.
Regards,
Hans