On Saturday 30 September 2017 02:51:27 Darren Hart wrote: > > +DELL SMBIOS DRIVER > > +M: Pali Rohár <pali.rohar@xxxxxxxxx> > > +M: Mario Limonciello <mario.limonciello@xxxxxxxx> > > +S: Maintained > > +F: drivers/platform/x86/dell-smbios.* > > Pali, do you agree with this? Yes, no problem. > > -static int __init dell_smbios_init(void) > > +static int dell_smbios_wmi_probe(struct wmi_device *wdev) > > +{ > > + /* no longer need the SMI page */ > > + free_page((unsigned long)buffer); > > + > > + /* WMI buffer should be 32k */ > > + buffer = (void *)__get_free_pages(GFP_KERNEL, 3); > > Assuming PAGE_SIZE here (I know, this driver, this architecture, > etc...). But, please use get_order() to determine number of pages > from a linear size: > > __get_free_pages(GFP_KERNEL, get_order(32768)); I agree that specifying size (instead of count) explicitly lead to more readable code. -- Pali Rohár pali.rohar@xxxxxxxxx
Attachment:
signature.asc
Description: This is a digitally signed message part.