On Tuesday 26 July 2016 22:19:09 Darren Hart wrote: > On Fri, Jul 22, 2016 at 03:01:24PM -0500, Mario Limonciello wrote: > > The Dell Rugged 7202 has 3 programmable buttons (labeled P1, P2, P3) > > and a detachable magnetic keyboard/mouse. > > > > Signed-off-by: Mario Limonciello <mario_limonciello@xxxxxxxx> > > +Pali > > Pali, any concerns? Hi! I'm not sure if KEY_PROG1/2/3 are good names here as we already use those for other actions (see bios_to_linux_keycode). Also there is: /* Wifi Catcher */ { KE_KEY, 0xe011, { KEY_PROG2 } }, But probably we do not have better names... Another small cosmetic change: align WMI codes, so 0x157 and 0x850 are at some column (similar like are formatted other actions). > > --- > > drivers/platform/x86/dell-wmi.c | 10 ++++++++++ > > 1 file changed, 10 insertions(+) > > > > diff --git a/drivers/platform/x86/dell-wmi.c b/drivers/platform/x86/dell-wmi.c > > index 15c6f11..6ba42d0 100644 > > --- a/drivers/platform/x86/dell-wmi.c > > +++ b/drivers/platform/x86/dell-wmi.c > > @@ -222,6 +222,16 @@ static const struct key_entry dell_wmi_extra_keymap[] __initconst = { > > > > /* Stealth mode toggle */ > > { KE_IGNORE, 0x155, { KEY_RESERVED } }, > > + > > + /* Rugged magnetic keyboard/mouse events */ > > + { KE_IGNORE, 0x156, { KEY_RESERVED } }, > > + { KE_IGNORE, 0x157, { KEY_RESERVED } }, > > + > > + /* Rugged programmable (P1/P2/P3 keys) */ > > + { KE_KEY, 0x850, { KEY_PROG1 } }, > > + { KE_KEY, 0x851, { KEY_PROG2 } }, > > + { KE_KEY, 0x852, { KEY_PROG3 } }, > > + > > }; > > > > static struct input_dev *dell_wmi_input_dev; > > -- > > 2.7.4 > > > > > -- Pali Rohár pali.rohar@xxxxxxxxx -- To unsubscribe from this list: send the line "unsubscribe platform-driver-x86" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html