On Wed, Sep 03, 2014 at 02:44:37PM +0300, Dan Carpenter wrote: > The current code just returns -EINVAL because mode can't be equal to > both 1 and 2. > > Also this function is messy so I have cleaned it up: > 1) Remove initializers like "int time = -1". Initializing variables to > garbage values turns off GCC's uninitialized variable warnings so it > can lead to bugs. > 2) Use kstrtoint() instead of sscanf(). > 3) Use SCI_KBD_MODE_FNZ and SCI_KBD_MODE_AUTO instead of magic numbers 1 > and 2. > 4) Don't check for "mode == -1" because that can't happen. > 5) Preserve the error code from toshiba_kbd_illum_status_set(). > > Signed-off-by: Dan Carpenter <dan.carpenter@xxxxxxxxxx> Queued, thanks. -- Darren Hart Intel Open Source Technology Center -- To unsubscribe from this list: send the line "unsubscribe platform-driver-x86" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html