Re: [PATCH] compal-laptop: correct invalid hwmon name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jul 09, 2014 at 09:12:42PM +0200, Roald Frederickx wrote:
> From: Roald Frederickx <roald.frederickx@xxxxxxxxx>
> 
> Change the name of the hwmon interface from "compal-laptop" to
> "compal". A dash is an invalid character for a hwmon name and caused
> the call to hwmon_device_register_with_groups() to fail.
> 
> Signed-off-by: Roald Frederickx <roald.frederickx@xxxxxxxxx>

Acked-by: Guenter Roeck <linux@xxxxxxxxxxxx>

> ---
> 
> diff --git a/drivers/platform/x86/compal-laptop.c
> b/drivers/platform/x86/compal-laptop.c
> index 7297df2..26bfd7b 100644
> --- a/drivers/platform/x86/compal-laptop.c
> +++ b/drivers/platform/x86/compal-laptop.c
> @@ -1028,7 +1028,7 @@ static int compal_probe(struct platform_device *pdev)
>  		return err;
> 
>  	hwmon_dev = hwmon_device_register_with_groups(&pdev->dev,
> -						      DRIVER_NAME, data,
> +						      "compal", data,
>  						      compal_hwmon_groups);
>  	if (IS_ERR(hwmon_dev)) {
>  		err = PTR_ERR(hwmon_dev);
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
> 
> 
> 
--
To unsubscribe from this list: send the line "unsubscribe platform-driver-x86" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Kernel Development]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux