Can't decode remote video if resolution is higher than the configured?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi there,

I'm running into a problem when the received video resolution is higher
than the one specified in the format.

Here is the scenario: PJSUA (the builtin app, I'm not using the API
myself) is configured to send and receive 720p video at 30fps (the codec
doesn't matter, the problem is the same).

The decoding channel is initially created for 720p resolution (according
to the logs) but quickly after the call is established a format change
event is received, changing the resolution to 1080p.

Then the logs start getting flooded with errors due to the decoding
buffer being to small:

I tried to trace this down and this is how far I got:

* Based on the error it looks like the value here should be higher:
* I tried multiplying it by 4 (just as a test) but then this assert
so it looks like the source and destination must matcch

At this point I'm out of ideas, I *think* a converter should've been
created somewhere after the format change, but I can't find a way to fix

Any help would be appreciated.



Visit our blog:

pjsip mailing list

[Index of Archives]     [Asterisk Users]     [Asterisk App Development]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [Linux API]
  Powered by Linux