Re: Fwd: Re: Error configuring 8.1.5 installation

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thank you Christoph.

I tried that with no success.  PKG_CONFIG_PATH is set:

printenv | grep open

ls /usr/openssl-1.1.1n/bin
c_rehash  openssl

(I also tried /usr/openssl-1.1.1n, same result) 

and the configuration is now:

./configure --prefix=/usr/php-8.1.5 --with-apxs2=/usr/apache-2.4.25/bin/apxs --
enable-fpm --with-fpm-user=phpfpm --with-fpm-group=phpfpm --with-fpm-systemd --
disable-short-tags --with-openssl --with-openssl-dir=/usr/openssl-1.1.1n/ --
with-zlib --with-pgsql=/usr/postgres-9.6.2 --with-pear

and it still reports that package openssl is not found.  I removed the reference
to with-libxml-dir because it was showing an error.

I'm still not convinced this is a bug; I think there is something fundamental
that I don't understand (?).


On Thu, 2022-04-21 at 11:39 +0200, Christoph M. Becker wrote:
> On 21.04.2022 at 03:20, John Iliffe wrote:
> > One thing that did occur to me was to grep "openssl" in the output stream from
> > ./configure and there is no reference until right at the end where it reports:
> > "
> > checking for openssl >= 1.0.2... no
> > configure: error: Package requirements (openssl >= 1.0.2) were not met:
> > 
> > No package 'openssl' found
> > "
> You can check config.log for more details.
> > All of the other "checking for..." entries seem to be either yes or I would
> > expect the no answer that I get.  The revised configuration file is:
> > 
> > ./configure --prefix=/usr/php-8.1.5 --with-apxs2=/usr/apache-2.4.25/bin/apxs --
> > enable-fpm --with-fpm-user=phpfpm --with-fpm-group=phpfpm --with-fpm-systemd --
> > disable-short-tags --with-openssl=/usr/openssl-1.1.1n --with-openssl-
> > dir=/usr/openssl-1.1.1n --with-zlib --with-pgsql=/usr/postgres-9.6.2 --with-pear
> > --with-libxml=/usr/lib64 CFLAGS=" -I/usr/openssl-1.1.1n/include/openssl"
> > OPENSSL_LIBS="-ldl -L/usr/openssl-1.1.1n/lib -l:libssl.a -l:libcrypto.a"
> > 
> > Is there any requirement for a specific order of parameters?  Basically I used
> > the command from the previous successful install of php-7.2.9.  I tried BOTH
> > include and include/openssl for the include path and it doesn't seem to make any
> > difference.  The actual header files are on include/ssl.
> As of PHP 7.4.0, openssl relies on a properly configured pkg-config.  As
> such, the path passed to --with-openssl is ignored; instead you need to
> set the environment variable PKG_CONFIG_PATH as needed for your system.
>  If configure runs successfully, there should be no need to set CFLAGS
> Also note that the PHP bugtracker is now at
> <> (<> has
> been mostly retired).
> --
> Christoph M. Becker

[Index of Archives]     [PHP Home]     [Apache Users]     [PHP on Windows]     [Kernel Newbies]     [PHP Install]     [PHP Classes]     [Pear]     [Postgresql]     [Postgresql PHP]     [PHP on Windows]     [PHP Database Programming]     [PHP SOAP]

  Powered by Linux