"Graham Cossey" <graham@xxxxxxxxxxxxxxx> wrote:
<quote -------------------------------------------------------> [snip]
$lastmonth = date("YmdHis", mktime(date("H"), date("i"), date("s"), date("m")-1, date("d"), date("Y"))); $countResult = db_query("SELECT count(*) AS msgCount FROM messages WHERE uid = '". $userID ."' AND fid = '". $fid ."' AND post_date <= '". $lastmonth ."'"); $countRow = db_fetch_array($countResult);
im then using $countRow as my variable but it keeps returning a value of zero.
[snikp]
Secondly I find it easier (to read) to code my SQL statements thus:
$countResult = db_query("SELECT count(*) AS msgCount FROM messages WHERE uid='$userID' AND fid='$fid' AND post_date<='$lastmonth'");
[snip] </quote ------------------------------------------------------->
I find queries even easier to read when they are written like this:
$countResult = db_query("SELECT count(*) AS msgCount
FROM messages
WHERE
uid='$userID' AND fid='$fid' AND post_date<='$lastmonth'
");
Neither PHP nor MySQL nor Postgres care about all the extra spaces.
-- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php