Re: Need help - Unable to grant a role

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thank you Erik!

Do we need to create hd*********' as both user and role?


On Thu, Feb 29, 2024 at 6:58 AM Erik Wienhold <ewie@xxxxxxxxx> wrote:
On 2024-02-29 02:06 +0100, Siraj G wrote:
> I have a PgSQL 15.4 database newly created. I created a user and is using
> it to restore a backup of another database, but unable to do so as it is
> failing with the below error:
> Error: role 'hd*********' does not exist.
> I even tried to grant pg_read_system_files and pg_write_system_files roles,
> even then I am getting the same error.
> Can someone please advise me on what I should do?

The error is pretty clear: you need to create that role first.

It probably stems from commands that try to change owners to that role
or grant privileges to it.  If you use pg_dump or pg_restore, you can
use options --no-acl and --no-owner to omit those commands if you don't
need them.


[Index of Archives]     [Postgresql Home]     [Postgresql General]     [Postgresql Performance]     [Postgresql PHP]     [Postgresql Jobs]     [PHP Users]     [PHP Databases]     [PHP Home]     [PHP on Windows]     [Kernel Newbies]     [PHP Classes]     [PHP Databases]     [Yosemite Forum]

  Powered by Linux