smart card not found

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I work on RHEL 5. I want to make my own pam module to read smart card. I desactivate RHEL's smart card manager.
I downloaded pam-pkcs11-0.6.1
I tried to authenticate with smart card to su -
1) when the card is inserted before running su -, there is no problem, but
2) when I run su - ( the program is waiting for my card ) then I inserted the card, the system did not detect my card.
in pkcs11_lib.c line 1144 :
 if (slot_num == 0) {
     printf("* find_slot_by_number : slot_num==0\n"); (*)// by me, to check if slog_num == 0 ( satisfied )
    for (slot_num = 0; slot_num < h->slot_count &&!h->slots[slot_num].token_present; slot_num++);

-- I get : slot_num == 0 by printing (*)
-- h->slot_count &&!h->slots[slot_num].token_present is never satisfied (always FALSE).
( I tested by printing )
-- Could someone tell me if there is a problem with pcsc-lite or/and the program who waits for a smart card event ?

Thanks for your help,


Avec Windows Live, vous organisez, retouchez et partagez vos photos.
Pam-list mailing list

[Index of Archives]     [Fedora Users]     [Kernel]     [Red Hat Install]     [Linux for the blind]     [Gimp]

  Powered by Linux