Re: Build problems on Windows - openssl3.07

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hello Madhusudan,

Just an idea: Have you built the x86 version before in the same directory tree? Quite some time ago, with a very much older version of openSSL, I ran into a similar problem when I tried to build on Windows.

Since that time, I always build the x86 and x64 versions in different directories.


Samantray Bhuyan, Madhusudan (GE Digital) wrote:
Hi Tom

Yes I have configured

ThirdPartySoftware\OpcUa\openssl-3.0.7>perl Configure VC-WIN64A

Configuring OpenSSL version 3.0.7 for target VC-WIN64A

Using os-specific seed configuration




Created makefile

Created include\openssl\configuration.h

And could see the generated makefile


## Makefile for OpenSSL


## WARNING: do not edit!

## Generated by from Configurations\common0.tmpl, Configurations\windows-makefile.tmpl

## via









*From:* Floodeen, Tom <thomas.floodeenjr@xxxxxxxxxxx>
*Sent:* 07 February 2023 00:23
*To:* Samantray Bhuyan, Madhusudan (GE Digital) <Madhusudan.SamantrayBhuyan@xxxxxx>; openssl-users@xxxxxxxxxxx
*Subject:* EXT: RE: Build problems on Windows - openssl3.07

*WARNING: *This email originated from outside of GE. Please validate the sender's email address before clicking on links or attachments as they may not be safe.

Did you configure it first?

perl Configure *VC-WIN64A*

(Add other options as desired.)


*From:* openssl-users <openssl-users-bounces@xxxxxxxxxxx <mailto:openssl-users-bounces@xxxxxxxxxxx>> *On Behalf Of *Samantray Bhuyan, Madhusudan (GE Digital)
*Sent:* Monday, February 6, 2023 11:38 AM
*To:* openssl-users@xxxxxxxxxxx <mailto:openssl-users@xxxxxxxxxxx>
*Subject:* Build problems on Windows - openssl3.07

I am building openssl 3.0.7 on windows using VS developer command prompt for x64 bit.

Checks :


Microsoft (R) C/C++ Optimizing Compiler Version 19.29.30145 for *x64*

Copyright (C) Microsoft Corporation.  All rights reserved.

usage: cl [ option... ] filename... [ /link linkoption... ]

I have set the 64 bit environment

C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Auxiliary\Build>vcvars64.bat


** Visual Studio 2019 Developer Command Prompt v16.11.14

** Copyright (c) 2021 Microsoft Corporation


[vcvarsall.bat] Environment initialized for: 'x64'

C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Auxiliary\Build>

But still getting the error

lib" /nologo /out:apps\libapps.lib @C:\Users\223036~1\AppData\Local\Temp\nm47B9.tmp

apps\lib\libapps-lib-*fmt.obj : fatal error LNK1112: module machine type 'x86' conflicts with target machine type 'x64'*

NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.29.30133\bin\HostX86\x64\lib.EXE"' : return code '0x458'


NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.29.30133\bin\HostX86\x64\nmake.exe"' : return code '0x2'


Madhusudan S

Martin Burnicki

Senior Software Engineer

MEINBERG Funkuhren GmbH & Co. KG
Email: martin.burnicki@xxxxxxxxxxx
Phone: +49 5281 9309-414

Lange Wand 9, 31812 Bad Pyrmont, Germany
Amtsgericht Hannover 17HRA 100322
Geschäftsführer/Managing Directors: Günter Meinberg, Werner Meinberg, Andre Hartmann, Heiko Gerstung

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux