> On 19 Feb 2025, at 17:23, Dave Airlie <airlied@xxxxxxxxx> wrote: > > On Thu, 20 Feb 2025 at 06:22, John Hubbard <jhubbard@xxxxxxxxxx> wrote: >> >> On 2/19/25 4:51 AM, Alexandre Courbot wrote: >>> Yes, that looks like the optimal way to do this actually. It also >>> doesn't introduce any overhead as the destructuring was doing both >>> high_half() and low_half() in sequence, so in some cases it might >>> even be more efficient. >>> >>> I'd just like to find a better naming. high() and low() might be enough? >>> Or are there other suggestions? >>> >> >> Maybe use "32" instead of "half": >> >> .high_32() / .low_32() >> .upper_32() / .lower_32() >> > > The C code currently does upper_32_bits and lower_32_bits, do we want > to align or diverge here? > > Dave. My humble suggestion here is to use the same nomenclature. `upper_32_bits` and `lower_32_bits` immediately and succinctly informs the reader of what is going on. — Daniel