Re: [PATCH v2 03/12] drm/i915: Make I2C terminology more inclusive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<

 



On Fri, May 03, 2024 at 02:04:15PM -0700, Easwar Hariharan wrote:
> On 5/3/2024 12:34 PM, Rodrigo Vivi wrote:
> > On Fri, May 03, 2024 at 06:13:24PM +0000, Easwar Hariharan wrote:
> >> I2C v7, SMBus 3.2, and I3C 1.1.1 specifications have replaced "master/slave"
> >> with more appropriate terms. Inspired by and following on to Wolfram's
> >> series to fix drivers/i2c/[1], fix the terminology for users of
> >> I2C_ALGOBIT bitbanging interface, now that the approved verbiage exists
> >> in the specification.
> >>
> >> Compile tested, no functionality changes intended
> >>
> >> [1]: https://lore.kernel.org/all/20240322132619.6389-1-wsa+renesas@xxxxxxxxxxxxxxxxxxxx/
> >>
> >> Reviewed-by: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx>
> >> Acked-by: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx>
> > 
> > It looks like the ack is not needed since we are merging this through
> > drm-intel-next. But I'm planing to merge this only after seeing the
> > main drivers/i2c accepting the new terminology. So we don't have a
> > risk of that getting push back and new names there and we having
> > to rename it once again.
> 
> Just to be explicit, did you want me to remove the Acked-by in v3, or will you when you pull
> the patch into drm-intel-next?
> 
> > 
> > (more below)
> > 
> >> Acked-by: Zhi Wang <zhiwang@xxxxxxxxxx>
> >> Signed-off-by: Easwar Hariharan <eahariha@xxxxxxxxxxxxxxxxxxx>
> > 
> > Cc: Jani Nikula <jani.nikula@xxxxxxxxx>
> > 
> > Jani, what bits were you concerned that were not necessarily i2c?
> > I believe although not necessarily/directly i2c, I believe they
> > are related and could benefit from the massive single shot renable.
> > or do you have any better split to suggest here?
> > 
> > (more below)
> > 
> >> ---
> >>  drivers/gpu/drm/i915/display/dvo_ch7017.c     | 14 ++++-----
> >>  drivers/gpu/drm/i915/display/dvo_ch7xxx.c     | 18 +++++------
> >>  drivers/gpu/drm/i915/display/dvo_ivch.c       | 16 +++++-----
> >>  drivers/gpu/drm/i915/display/dvo_ns2501.c     | 18 +++++------
> >>  drivers/gpu/drm/i915/display/dvo_sil164.c     | 18 +++++------
> >>  drivers/gpu/drm/i915/display/dvo_tfp410.c     | 18 +++++------
> >>  drivers/gpu/drm/i915/display/intel_bios.c     | 22 +++++++-------
> >>  drivers/gpu/drm/i915/display/intel_ddi.c      |  2 +-
> >>  .../gpu/drm/i915/display/intel_display_core.h |  2 +-
> >>  drivers/gpu/drm/i915/display/intel_dsi.h      |  2 +-
> >>  drivers/gpu/drm/i915/display/intel_dsi_vbt.c  | 20 ++++++-------
> >>  drivers/gpu/drm/i915/display/intel_dvo.c      | 14 ++++-----
> >>  drivers/gpu/drm/i915/display/intel_dvo_dev.h  |  2 +-
> >>  drivers/gpu/drm/i915/display/intel_gmbus.c    |  4 +--
> >>  drivers/gpu/drm/i915/display/intel_sdvo.c     | 30 +++++++++----------
> >>  drivers/gpu/drm/i915/display/intel_vbt_defs.h |  4 +--
> >>  drivers/gpu/drm/i915/gvt/edid.c               | 28 ++++++++---------
> >>  drivers/gpu/drm/i915/gvt/edid.h               |  4 +--
> >>  drivers/gpu/drm/i915/gvt/opregion.c           |  2 +-
> >>  19 files changed, 119 insertions(+), 119 deletions(-)
> >>
> 
> <snip>
> 
> >> diff --git a/drivers/gpu/drm/i915/display/intel_ddi.c b/drivers/gpu/drm/i915/display/intel_ddi.c
> >> index c17462b4c2ac..64db211148a8 100644
> >> --- a/drivers/gpu/drm/i915/display/intel_ddi.c
> >> +++ b/drivers/gpu/drm/i915/display/intel_ddi.c
> >> @@ -4332,7 +4332,7 @@ static int intel_ddi_compute_config_late(struct intel_encoder *encoder,
> >>  									connector->tile_group->id);
> >>  
> >>  	/*
> >> -	 * EDP Transcoders cannot be ensalved
> >> +	 * EDP Transcoders cannot be slaves
> > 
> >                                      ^ here
> > perhaps you meant 'targeted' ?
> > 
> >>  	 * make them a master always when present
> 
> <snip>
> 
> This is not actually I2C related as far as I could tell when I was making the change, so this was more of a typo fix.
> 
> If we want to improve this, a quick check with the eDP v1.5a spec suggests using primary/secondary instead,
> though in a global fashion rather than specifically for eDP transcoders. There is also source/sink terminology
> in the spec related to DP encoders.
> 
> Which would be a more acceptable change here?

hmmm probably better to split the patches and align with the spec naming where it applies.
and with i2c name where it applies.

> 
> Thanks,
> Easwar



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux