On Wed, May 01, 2019 at 05:01:08PM -0500, Gustavo A. R. Silva wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace code of the following form: > > sizeof(struct xt_hashlimit_htable) + sizeof(struct hlist_head) * size > > with: > > struct_size(hinfo, hash, size) > > This code was detected with the help of Coccinelle. Applied, thanks.