On Tue, Jan 08, 2019 at 05:35:34PM +0100, Florian Westphal wrote: > With CONFIG_RETPOLINE its faster to add an if (ptr == &foo_func) > check and and use direct calls for all the built-in expressions. > > ~15% improvement in pathological cases. > > checkpatch doesn't like the X macro due to the embedded return statement, > but the macro has a very limited scope so I don't think its a problem. > > I would like to avoid bugs of the form > If (e->ops->eval == (unsigned long)nft_foo_eval) > nft_bar_eval(); > > and open-coded if ()/else if()/else cascade, thus the macro. Applied, thanks.