On Tue, Jul 17, 2018 at 07:25:17PM +0200, Fernando Fernandez Mancera wrote: > Signed-off-by: Fernando Fernandez Mancera <ffmancera@xxxxxxxxxx> > --- > include/linux/netfilter/nf_osf.h | 2 + > include/uapi/linux/netfilter/nf_osf.h | 5 + > include/uapi/linux/netfilter/xt_osf.h | 8 -- > net/netfilter/Kconfig | 10 +- > net/netfilter/Makefile | 1 + > net/netfilter/nf_osf.c | 7 ++ > net/netfilter/nfnetlink_osf.c | 134 ++++++++++++++++++++++++++ BTW, could you make an initial patch to rename nf_osf.c to nfnetlink_osf.c and then add this new code to it. I don't think we need two separated modules nf_osf and nfnetlink_osf, with one single module should be good. So patchset should look like: 1) Rename net/netfilter/nf_osf.c to net/netfilter/nfnetlink_osf.c, same with header file and don't forget about the Kconfig and Makefile bits. 2) Extract nfnetlink_subsystem code from xt_osf.c to nfnetlink_osf.c 3) Add nft_osf.c :-) OK? -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html