On Wed, Aug 23, 2017 at 10:41:24PM +0200, Pablo M. Bermudo Garay wrote: > Just a small refactor patch in order to improve the code readability. Applied with changes, see below. > Signed-off-by: Pablo M. Bermudo Garay <pablombg@xxxxxxxxx> > --- > include/uapi/linux/netfilter/nf_tables.h | 2 +- > net/netfilter/nft_limit.c | 30 +++++++++++++++--------------- > 2 files changed, 16 insertions(+), 16 deletions(-) > > diff --git a/include/uapi/linux/netfilter/nf_tables.h b/include/uapi/linux/netfilter/nf_tables.h > index be25cf69295b..dc7661c293b8 100644 > --- a/include/uapi/linux/netfilter/nf_tables.h > +++ b/include/uapi/linux/netfilter/nf_tables.h > @@ -946,7 +946,7 @@ enum nft_ct_attributes { > > enum nft_limit_type { > NFT_LIMIT_PKTS, > - NFT_LIMIT_PKT_BYTES > + NFT_LIMIT_BYTES Remember that whatever is exposed through uapi files cannot ever be changed. This exposes the API to userspace, so if change this, we may break compilation of userspace tool, that use these headers. So rule of thumb is: Whatever is exposed through uapi, it is set in stone forever, even if we don't like it. So I have taken this, but I have undo this change. Thanks. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html