On Sat, Mar 25, 2017 at 05:57:55PM +0530, Arushi Singhal wrote: > This patch removes typedefs from struct and renames it from "typedef struct > field_t" to "struct field" as per kernel coding standards." > > Signed-off-by: Arushi Singhal <arushisinghal19971997@xxxxxxxxx> > --- > net/netfilter/nf_conntrack_h323_asn1.c | 68 +++++++++++++++++----------------- > 1 file changed, 34 insertions(+), 34 deletions(-) > > diff --git a/net/netfilter/nf_conntrack_h323_asn1.c b/net/netfilter/nf_conntrack_h323_asn1.c > index 89b2e46925c4..fb8cf238a76f 100644 > --- a/net/netfilter/nf_conntrack_h323_asn1.c > +++ b/net/netfilter/nf_conntrack_h323_asn1.c > @@ -77,7 +77,7 @@ > > > /* ASN.1 Field Structure */ > -typedef struct field_t { > +struct field { Probably better if you rename this to 'struct h323_field' to make sure compilation doesn't break due to structure name pollution. And we also got a report from kbuild robot that would be good to investigate. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html