On Tuesday 2016-08-02 14:17, Baole Ni wrote: >I find that the developers often just specified the numeric value >when calling a macro which is defined with a parameter for access permission. >As we know, these numeric value for access permission have had the corresponding macro, >and that using macro can improve the robustness and readability of the code, >thus, I suggest replacing the numeric parameter with the macro. > > static int ip_vs_conn_tab_bits = CONFIG_IP_VS_TAB_BITS; >-module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, 0444); >+module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, S_IRUSR | S_IRGRP | S_IROTH); We have S_IRUGO for this. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html