On 25.11, Pablo Neira Ayuso wrote: > #define TYPE_MAX (__TYPE_MAX - 1) > diff --git a/include/proto.h b/include/proto.h > index a43bf98..41af0c1 100644 > --- a/include/proto.h > +++ b/include/proto.h > @@ -176,7 +176,7 @@ enum ip_hdr_fields { > IPHDR_INVALID, > IPHDR_VERSION, > IPHDR_HDRLENGTH, > - IPHDR_TOS, > + IPHDR_DSCP, Shouldn't we keep both? I think it should work to do that or at least not be difficult to make it work. > diff --git a/src/proto.c b/src/proto.c > index 28b93cb..0e5932d 100644 > --- a/src/proto.c > +++ b/src/proto.c > ... > +static const struct datatype dscp_type = { > + .type = TYPE_DSCP, > + .name = "dscp_type", We usually only add a _type suffix if that's really a part of the name, pkt dccp_pkttype. -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html